Quick Reference Guide – TM Designer
1.

Activity
Create a New Project.

Actions
Click 'New Project' button
OR
Select File->New ->New
Project
Select File->New ->New Panel

Keyboard shortcut
Ctrl +Shift + N

Ctrl + O

2.

Create a new Panel as part of the
new project

3.

Open a Project.

4.

Save Project

5.

Save Project as …

6.

Print

Click 'Open Project' button
OR
Select File->Open
Click 'Save' button (if the project
has already been saved before)
OR
Select File->Save
Click 'Save' button (if the project
has not been saved before)
OR
Select File->Save
Select File->Print

7.

Print 3D view of the panel

Select File->Print 3D

8.

Export to PDF

Select File->Export to PDF

9.

Export to DXF

Select File->Export to DXF

10.

Draw a Panel Design Element
(PDE).

Click button for select particular
PDE and draw it using Mouse.

11.

Deselect PDE tool.

12.

Change properties of a PDE.

13.
14.

Rotate PDE by 900
Rotate PDE by 1800

Click on selected tool button
again.
Right click on PDE and select
'Properties...'
Double click on PDE.
Right click on PDE and select
Flip

Ctrl + N

Ctrl +S

F12

Ctrl + P

Ctrl + Shift + E

Esc

15.

Delete PDE

16.

Copy PDE

17.

Cut PDE

18.

Paste PDE

19.

Select all PDEs

20.
21.
22.

Undo
Redo
View Project Properties

23.
24.

View Panel Properties
View/Hide Toolbox

25.

Select/Edit Panel Depths

26.

Change the Prices and Assembly
times of Electrical components.
Change the application font size
Change the customer logo
Generate Panel
View/Hide Doors and Covers
Zoom In/Zoom Out
Switch to 2D View
Switch to 3D View

Right click on PDE and select
Delete
Right click on PDE and select
'Copy'
OR
Select Edit->Copy
Right click on PDE and select
'Cut'
OR
Select Edit->Cut
Right click on drawing area and
select 'Paste'
OR
Select Edit->Paste
Right click on drawing area and
select 'Select All'
Select Edit->Undo
Select Edit->Redo
Select View-> Project
Properties
Select View-> Panel Properties
Select View-> Toolbars->
Toggle Toolbox
Select Tools->Select Panel
Depths..
Select Tools->Customize>Electrical Components..
Select Tools->Settings...
Select Tools->Settings...
Select Tools->Generate Panel

27.
28.
29.
30.
31.
Mouse Scroll
32.
33.
34.
35.
36. View Bill of Material
Select View->Bill of Material
* You have to select PDE/PDEs before apply this shortcut.

Del*
Ctrl + C *

Ctrl + X *

Ctrl + V

Ctrl + Z
Ctrl + Y

Alt + V, P
Ctrl + T

Ctrl + E

Ctrl + G
Ctrl + D
Alt + 2
Alt + 3

Ctrl + B

User interface overview
General screen

Menus
File

Edit

View

Tools Menu

Help Menu

Dialogs

Designing a panel
In TMD, panels are first designed in 2D by drawing a set of Panel Design Elements (PDE).

These elements represent a set of items which might define compartments or groups of Elsteel items
which are usually related. PDEs might represent either internal items or external items which will define
the panel structure.
Once the 2D design of the panel is done, the actual panel has to be generated. In this process we check
all the characteristics of all PDEs and create and position the all the items required. Until generation, the
panel does not really exist and as such, the Bill of Materials (BOM) will be empty1.
The panel items will be visible in the 3D view. In that view it is possible delete or modify the position and
rotation of each item. Changes made to Elsteel items will not be propagated to the 2D design and are
lost if at some point the panel is regenerated. For this reason we strongly suggest to only modify the
panel once the 2D design is satisfactory.

Drawing the panel in 2D
To draw a panel you must select the desired tool from the left side bar. In general, the selected button
will be highlighted in red and the mouse pointer will change to a cross. In this state you can click and
drag on the drawing area to define the desired size of the PDE.
To allow a faster drawing process, PDEs position will snap to the nearest point of the drawing grip. The
grid size can be modified as described in Modifying the snap grid size.

Modifying the snap grid size
In order to change the grid size in 2D, you can

The panel Design Elements
All panel design elements which have included to TMD list in below.
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.
1

Fixed Type Mounting Plate
Meter Compartment
Mounting Plate
Din Insert
External Gland Plate
Steel Blank Front Plate
Super flex insert
SS Plate
Internal Gland Plate
CT Insert
Escutcheon Door
Cable Gland Frame

As an exception, ítems added as accesories will appear direclty on the BOM even if the panel has not been
generated.

13.
14.
15.
16.
17.
18.
19.
20.
21.
22.
23.
24.
25.
26.
27.
28.
29.
30.
31.
32.
33.
34.
35.
36.

Aluminum Gland Plate
Cable Gland Plate
Gland Plate IP55
Gland Plate With Slider
Knock Out Plate
Quick Gland Plate
19" Swing Frame for TM
Separation Plate
Vertical Separation plate
Horizontal separation plate
Chassis Profile
Din Insert DB2
Blank Front Plate
Adjustable Mounting Plate
Fixed Type Mounting Plate
25mm Filling Profile
Din Rail
Insert For Breakers
Flexi bar and MCCB Kit Properties
Neutral Link Properties
Cable Properties
Gland Plates For VSP/Compartments
Cable Box
Crossbar Frame

1.Fixed Type Mounting Plate
This is the PDE of designing the fixed type mounting plate. If panel form type is 1 or 2 then this PDE
does not define a front item. But you can add a door as the front item (If it is necessary) to this by
checking the "Has a front door" checkbox of properties widget of this. If panel form type is 3 or 4 then
the PDE define a door as its front item and also create a compartment. What PDE create is one fixed
type mounting plate and if PDE defined a front item then create a defined type front item and front
item's floating elements.

2. Meter Compartment

This is the PDE of designing the meter compartment. By default this represented type is Norwegian
standard meter compartment. But you can change it as Danish standard meter compartment via
properties widget. Also you can add(If you need) a Norwegian door for this if you have selected this
represented type as Norwegian standard meter compartment. If PDE represented type is Danish
standard meter compartment then this define a front item as the meter compartment. Else if the PDE
represented type is Norwegian standard meter compartment and it has a Norwegian door then this
define a front item as Norwegian door. Else the PDE does not define a front item. What PDE create is a
selected type meter compartment and a Norwegian door (If you requested).

3. Mounting Plate
This is the PDE of designing the mounting plate. This does not define a front item. By default PDE
represented type depend on the panel version(If panel version is V1 then default represented type is
MP. Else if panel version is V2 then default represented type is MPV2). But you can change represented
type via properties widget. And you can change the this z-position through properties widget. By default
z-position value is zero. Also you can change the mounting plate color is AluZinc or not (By default
mounting plate color is AluZinc). By default mounting plate mounting option is vertically. But you can
change the mounting option as longitudinally (If you need) . This properties widget using you can add a
crossbar frame or cable holders (as you need). This PDE will use the mounting bracket type according to
the represented item type. But you can change the mounting bracket type via widget. And this widget
provide to add mounting plate accessories such as heavy duty support, filler profile, mounting plate
sliders, frame supporter, fixing studs for 2mm, fixing studs for 3mm. Mounting plate can contain items
are electrical components and din ails. What PDE create is a represented type mounting plate, selected
type mounting plate brackets(Unless bracket type is none). Following mounting plate accessories will
create according to your requests. cable holders, a crossbar frame, a heavy duty support, filler
profile(s), a mounting plate sliders, a frame supporter, a fixing studs for 2mm, a fixing studs for 3mm.

4. Din Insert
This is the PDE of designing the steel din insert. The PDE define a front as a door. This represented type
is DINI. This can contains types are electrical components. You can use to add electrical components to
this via "Add Electrical Components" action of this context menu. What PDE create is a steel din insert,
selected type front door and floating elements of the door.

5. External Gland Plate

This is the PDE of designing the external gland plate. This define a front type as external gland plate. The
PDE properties widget through you can change it color is aluminum or not. By default this color is not
aluminum. What PDE create is an external gland plate.

6. Steel Blank Front Plate
This is the PDE of designing the steel blank front plate. The PDE define a front item as a door. What PDE
created is a steel blank front plate, a selected type front door and floating elements of the door.

7. Super Flex Insert
This is the PDE of designing the super flex insert. By default this front type is door. But you can change
the front type as cover(if you need) via properties widget. And also you can select the super flex insert
depth by using the widget. By default this depth is 140. This properties widget provide a optional
information gathering interface. That using you can change bars positions of the super flex insert. Super
flex insert can contain items are electrical components and din rails. What PDE create is a super flex
insert, selected front item and its floating elements.

8. SS Plate
This is the PDE of designing the SS plate. This does not define a front item. The PDE represented type is
stainless steel plate. What PDE create is a SS Plate.

9. Internal Gland Plate
This is the PDE of designing the internal gland plate. This does not define a front item. The PDE
represented type is internal gland plate. You can change this color as aluminum or not. By default this
color is not aluminum. What PDE create is an internal gland plate.

10. CT Insert

This is the PDE of designing the current transformer insert. This is a external item(Front type is itself).
The PDE represented type is CTIN. You can change this version type through properties widget. By
default this version type take the panel version. And also you can change the ampere rate via the
widget. By default ampere rate is 400A. Also you can add a door seal system, bus bar angle by using the
widget. What PDE create is a CT Insert. Also will create a door seal system and a bus bar angle according
to the your requests.

11. Escutcheon Door
This is the PDE of designing the escutcheon door. This define the front item as a door. The PDE
represented type is escutcheon door. You can change this z-position via properties widget. By default zposition is zero. What PDE create is an escutcheon door, selected front door and floating elements of
the front item.

12. Cable Gland Frame
This is the PDE of designing the cable gland frame. This does not define a front item. The PDE
represented item type is CGF(regular cable gland frame). But you can change it as CGF for mounting
plate sliders via properties widget. Also you can change the color is AluZinc or not, z-position by using
the widget. By default color is not AluZinc and z-position is zero. Cable gland frames can be add to
frontal side or bottom side of the panel. You can add a cross bar frame for frontal side cable gland
frames(The properties widget support for it). Cable gland frame can contains type are aluminum gland
plate, knockout plate, cable gland plate, quick gland plate, gland plate IP55 and gland plate with sliders.
This gland plates you can create and add to this via "Add Gland Plate" action of the PDE context menu.
What PDE create is a cable gland frame of selected type and a crossbar frame (If you requested).

13. Aluminum Gland Plate
This is the PDE of designing the aluminum gland plate. This does not define a front item. And this
represented type is Aluminum gland plate . This can be contain onto a cable gland frame. What PDE
create is an aluminum gland plate.

14. Cable Gland Plate

This is the PDE of designing the cable gland plate. This does not define a front item. And this
represented type is cable gland plate . This can be contain onto a cable gland frame. What PDE create is
a cable gland plate.

15. Gland Plate IP55
This is the PDE of designing the gland plate IP55. This does not define a front item. And this represented
type is gland plate IP55 . This can be contain onto a cable gland frame. What PDE create is a gland plate
IP55.

16. Gland Plate With Slider
This is the PDE of designing the gland plate with sliders. This does not define a front item. And this
represented type is gland plate with slider . You can change the slider open area through properties
widget. By default open area take the minimum value of the open area. This can be contain onto a cable
gland frame. What PDE create is a gland plate with slider.

17. Knock Out Plate
This is the PDE of designing the knock out plate. This does not define a front item. And this represented
type is knock out plate . This can be contain onto a cable gland frame. What PDE create is a knock out
plate.

18. Quick Gland Plate
This is the PDE of designing the quick gland plate. This does not define a front item. And this
represented type is quick gland plate . This can be contain onto a cable gland frame. What PDE create is
a quick gland plate.

19. 19" Swing Frame for TM

This is the PDE of designing the 19" swing frame. This does not define a front item. What PDE create is a
swing frame.

20. Separation Plate
This is the PDE of designing the regular separation plates. This does not define a front item. You can
change this represented item type via properties widget. By default represented item type is standard
type separation plate(SP). Also you can change the z-position and color AluZinc or not through
properties widget. By default z-position is zero and color is not AluZinc. This properties widget using you
can select the separation plate mounting option. By default mounting option is vertically. If you want to
rotate the longitudinal or side mounting plates by 90 degrees, this widget provide option for that. Also
you can add a crossbar frame to this by using properties widget. What PDE create is a represented type
separation plate and a crossbar frame (If you requested).

21. Vertical Separation Plate
This is the PDE of designing the vertical separation plates. This does not define a front item. The PDE
represented type is vertical separation plate. You can change this longitudinal length via properties
widget. By default longitudinal length take minimum available value of longitudinal lengths. And you can
also add cable boxes via cable box tab of the properties widget dialog. And also you can add glands via
"gland plates for VSP/ Compartments " tab of the widget. What PDE create is a couple of vertical
separation plates, added glands and added cable boxes.

22. Horizontal Separation Plate
This is the PDE of designing the horizontal separation plates. This does not define a front type. The PDE
represent type is horizontal separation plate. You can change this longitudinal length via properties
widget. By default longitudinal length take minimum available value of longitudinal lengths. What PDE
create is a horizontal separation plate.

23. Chassis Profile

This is the PDE of designing the chassis profile. This define front as a door. PDE properties widget has a
option to add a "flat and bottom cover". By default, A "flat and bottom cover" has added to chassis
profile PDE. Also properties widget has a option to select the version of the chassis profile. By default
the chassis profile has taken its version as the panel version. Chassis profile can contain items are din
insert DB2, adjustable mounting plate DB2, fixed type mounting plate DB2, blank front plate DB2,
25mm filling profile, plastic din insert, din rail and inserts for breakers. What PDE create is one chassis
profile, one defined type door and its floating elements. A top and bottom cover creation depend on the
designer request.

24. Din Insert DB2
This is the PDE of designing the din insert DB2. This does not define a front item. By default PDE
represented item type is din insert DB2 (DIDB). But you can change represented item type as plastic din
insert(PDIDB) via properties widget. And also you can change this color as Aluminum or not. By default
this color is Aluminum. Din insert DB2 can be contained into chassis profile. This can contain the
electrical components. You can add electrical components to this via "Add Electrical components" action
of this context menu or directly create the electrical components and drag and drop onto this PDE. What
PDE create is a din insert DB2 only.

25. Blank Front Plate
This is the PDE of designing the blank front plate DB2. This does not define a front item. You can select
seal type blank front plate or not via properties widget. By default this PDE represent a not seal type
blank front plate. And blank front plate color will take the container color if it has a chassis profile
container and if it is not a seal type blank front plate. Blank front plate DB2 can be contained into chassis
profile. What PDE create is a blank front plate DB2 only.

26. Adjustable Mounting Plate
This is the PDE of designing the adjustable mounting plate DB2. This does not define a front item.
Adjustable mounting plate DB2 can be contained into chassis profile. And this can contain the electrical
components. What PDE create is adjustable mounting plate DB2 only.

27. Fixed Type Mounting Plate
This is the PDE of designing the fixed type mounting plate DB2. This does not define a front item. Fixed
type mounting plate DB2 can be contained into chassis profile. And this can contain the electrical
components. What PDE create is fixed type mounting plate DB2 only.

28. 25mm Filing Profile
This is the PDE of designing the 25mm filling profile. This does not define a front item. And this can be
contained into chassis profile. 25mm filling profile color will take the container color if it has a chassis
profile container. What PDE create is a 25mm filling profile only.

29. Din Rail
This is the PDE of designing the din rail. This does not define a front item. Din rail has three different
types, such as full length din rail, din rail with fixing brackets 600 and din rail with adjustable fixing
brackets 600. By default din rail represented type is full length din rail. You can change the represented
type via properties widget. Also properties widget has 4 options to select the din rail brackets, such as
none, brackets for din rail, adjustable din rail brackets and din rail holders. By default PDE use the
bracket type as "brackets for din rail". You can change the din rail length by using resizing nodes or
length spin box of the properties widget. And also properties widget provide a z-position changing
option. By default z-position is zero.
Din rail can be contained into chassis profile, mounting plate and super flex insert. And this can contain
the electrical components. What PDE create is one din rail, one couple of selected bracket type unless
selected bracket type is none.

30. Insert For Breakers
This is the PDE of designing the insert for breakers. This does not define a front item. If you click the
Insert for breakers button in the tool box then pop up the insert for breakers selector dialog. That dialog
using you can create few insert for breakers as you need. And properties widget using you can change
the properties. This can be contained into chassis profile. And also this can contain the electrical
components. What PDE create is a insert for breaker for selected order number.

31. Flexi bar and MCCB Kit Properties
Flexi bar and MCCB kit properties widget is a helping widget for PDEs. This help to create flexi bars,
MCCB kits and related accessories. This widget has mainly three types, such as flexi bar, 3 pole MCCB kit
and 4 pole MCCB kit. You have to select the type what you want to create using this widget. By default
selected type is flexi bars. This widget provide different selection interfaces for each selected types. And
using that interfaces, you can select what you want to create. This properties widget used at electrical
component PDE. What widget create is flexi bars, flexi bar holders, selected type connecting accessories
and MCCB kits (Those items count, creation or not depend on your selection).

32. Neutral Link Properties
Neutral link properties widget is a helping widget for PDEs. This help to create neutral links. By default
this represented neutral link type is "NEU 250". But you can change it via properties widget. This widget
used at electrical component PDE. What widget create is a neutral link.

33. Cable Properties
Cable Properties widget is a helping widget for PDEs. This help to create cables. This widget used at
electrical component PDE. This default represented cable type and cable count depend on component
details of the electrical component PDE(If this PDE is electrical component PDE). And also you can select
the cables connecting accessory type via properties widget. By default connecting accessory type is
"Thread forming Hex. Flange Head Screw".

34. Gland Plates For VSP/Compartments
Gland Plates For VSP/Compartments widget is a helping widget for PDEs. This help to create glands for
vertical separation plates, compartments. This has three gland types, such as quick gland, polycarbonate
gland and rubber grommet. You can select how many glands you want to create for each gland type.
This widget used at fixed type compartment PDE and Vertical separation plate PDE. What PDE create is
selected quantity of glands for each type.

35. Cable Box
Cable box widget is a helping widget for PDEs. This help to create cable boxes for vertical separation
plates, fixed type compartments. This has mainly two types of cable boxes. There are V1 and V2. You can
select the cable boxes version and add cable boxes of the selected version. Also you can add the glands
for cable boxes (Glands available for V1 cable boxes only). What PDE create is added cable boxes and
glands of those.

36. Crossbar Frame
Crossbar frame widget is a helping widget for other widgets. This create a crossbar ring around the PDE
item. This embedded to the cable gland frame widget, mounting plate widget and separation plate
widget. What PDE create is crossbars.

